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1 Introduction
1.1 Overview
This operational manual provides a general instruction of how to use a Software. The
manual assumes that the user have a working knowledge of weaving, computer and
its operating conventions, including how to use a mouse and standard menus and
commands.

1.2 Usage and Warning
Media Lab Asia is trying to enhance its product so that you can get the quality product.
Therefore, it may happen that the user manual and program you are using are
inconsistent. It means you will find some new features in the different version. We are
trying to enhance the application and trying to make it as simple as we can. An online
help is also being provided through bunai.medialabasia.in. We would like to get
comments, feedbacks, and suggestions from our users along with the report on
malfunctioning. We will try to incorporate all of you feedback /suggestions but
sometimes we will not be able to implement all your suggestions.

1.3 About software
This tool is used to make all over figured fabrics such as Saree, brocades, dress
material and other cloth accessories viz. stole, scarf etc. The fabrics are woven on a
loom having Jacquard (s) attachment to control individual warps. Fabrics of this type
are costly because of the time and skill involved in making the Jacquard cards,
preparing the loom to produce a new pattern, and the slowness of the weaving
operation. The Jacquard weave usually combines two or more basic weaves, with
different weaves used for the design and the background. The software helps the user
in design making, assigning different weaves in the design and creating graph of the
design. User can either take the printout of design or give the command to
computerized jacquard card punching machine.

1.4 Application Requirements
1.4.1 Hardware Requirement
The software will work with the following configuration smoothly:




Processor: Intel i5 Processor or higher
RAM: Minimum 4 GB (for smooth functioning 8 GB)
Graphics- 2GB dedicated

1.4.2 Software Requirement
The minimum Software requirement for running Open Source CAD Tool is:




Operating System: Windows 2007 or above.
JRE : 1.7 or above
MySQL : 5.0 or above

1.5 Program Installation
a) Copy the Myapp folder to the local disk
b) Run the bunaiSetup.bat File.
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Software Installation

1.6 Running the Application



Click on the buni.jar file in mla_cad folder
The following user Login screen will appear

Login Screen

1.6.1 Create New User - Sign Up
User need to fill the details and accept the Terms & Condition and click on the submit
Button.
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Create New User

1.6.2 Login the Existing Users – Sign In
User need to enter the user name and password and click on Sign In Button.
1.6.3 Forget Password
 In case user forgot the password, he/she needs to clock on the Forgot Password Button
and the below screen will appear.
 User needs to enter username and email and a new password will be sent to the
registered email ID.

Forget Password
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1.7 Dashboard
After the Login, a dashboard screen will appear as below:

The dashboard shows the recent work done by the user in the form of recent artwork,
weaves and fabrics. There will be the name of the user on the screen i.e. Welcome
‘User Name’.

1.8 Configure the Program – First Time
1.8.1 Fabric and Artwork Size
 User need to enter the size of the different component of Saree viz. Border, Cross
Border, Pallu (Anchal), Body (Pot), Conia and Skart.
1.8.2 Warp thread
User need to enter the yarn properties viz. type, color, count, twist etc.
1.8.3 Weft thread
User need to enter the yarn properties viz. type, color, count, twist etc.
1.8.4 Miscellaneous
User need to specify the graph type, repeat, maximum float, binding, protection, color
palette,
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1.8.5 User Settings
User need to set the language, resolution, Dots Per Inch, measurement system,
currency, theme, font of the header and path for saving the different files viz. export,
import, log etc.

1.8.6 User Preferences
User need to specify the preferences to authenticate the data (work done) i.e. public,
protected or private. Based on the authentication, data will be shared to other users.

1.8.7 User Profile
User can edit its profile
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2 Fabric designer Module
2.1 New fabric creation
You can create new fabric by clicking on

New icon in the File Menu.

2.1.1 Selection of Base Weave
To create a fabric user need to select base
weave first from the library. On clicking on
new icon in the File Menu, an image browser
Window will pop showing the weave library for
the base of the fabric. User need to select at
least one weave and this will reflect on the
fabric as base weave. If required weave is not
available in the library, user need to take the
help of weave editor module to create the
weave. This weave can be changed during
the weave assignment to the artwork.
After selecting the base weave, a base fabric
will be reflected on the next window.
2.1.2 Artwork Assignment
To assign an artwork in the base fabric, user can either select Artwork Assignment
icon in the File Menu or user need to right click on the fabric and artwork assignment
option may be selected.
In the artwork assignment section, the
artwork will be displayed in the different
colours. Each colour of the artwork reflects a
weaving pattern. User need to select a
weave for each and every colour of the
artwork.

2.1.3 Assigning Weave for Base fabric (Warp and Weft)
When user will select the artwork, two rows of boxes will appear if the 0 Extra wefts
are selected in the Weaving Mode. Number of boxes in the row will depend on the
number of colors in the artwork. In the first row, all the boxes will be filled with the
colors of the artwork. The second row of boxes is for the base weave of the fabric. By
default base weave of the fabric will be assigned to the first box. User can assign the
weaves in the other boxes by clicking on the box.
2.1.4 Assigning weave for Artwork –Extra Weft
In case of extra weft user needs to select more than 0 extra weft in the weaving mode.
If user select 1 extra weft, 1 row will be added, in case of 2 extra wefts, 2 rows will be
added.
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2.1.5 Assigning less extra wefts than colors of Artwork
If the number of colors are more than user want to use the extra weft then it will epend
on the number of extra wefts selected by the user for example there are 4 colors in the
artwork and user wants to use only 1 extra weft in that case use needs to assign the
base wave in the second row, weaves for extra weft in the third row of the boxes.
2.1.6 Removing the weave
In case user needs to remove the weave from the box, ctrl + click on the box.
2.1.7 Weaving Mode
Use need to select the weaving mode in the form of no. of extra wefts. Based on the
no of extra wefts selected, boxes will reflects below the respective colour in the
artwork.
2.1.8 Fabric Type
In the fabric type, user can select type of the fabric in the form of kadhua, fekuwa-with
foat, fekuwa-with cutwork, tanchoi, float binding-regular, float binding-irregular. Based
on the selection, backside view of the fabric will be changed.
2.1.9 Weave of Original Size of Artwork
The user has to option to fix the size of the fabric. First based on the fabric preferences,
the size of the motif will be calculated; second based on the original size of the motif.
User need to select option to keep the original size of the artwork.
2.1.10 Don’t touch border of Motif
This option is to keep the outline of the artwork smooth. User need to select the option
of Don’t touch the border o Motif.

2.2 Fabric Edit
After creating the fabric, user can edit
the fabric from the different aspects i.e.
weave,
yarn,
density,
thread
sequencing as per the requirement
2.2.1 Edit/Change
Artwork
User can change the artwork, weaves
assigned to the fabric by clicking on
the Edit -> Artwork Assignment or right
click and then select Artwork Assignment option.

2.2.2 Weaving Pattern
User can edit the weaving pattern manually as and when needed, all the changes in
the weaving pattern will be reflected in the graph as well.
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2.2.3 Graph Correction
User can edit the graph manually to give
the finishing touch for the artwork. There
will be the boxes for warp, weft and
extra wefts which user need to select
the box wherever changes are required.
In case user wants to do some changes
in the artwork then he/she needs to
select the green box of extra weft and
start editing the artwork with the green
colour.

2.2.3.1

Float finding

If user wants to find the maximum float size in the fabric then user need to enter the
maximum float value in the text box and select the box of show floats.

2.2.3.2

Float Binding

User has two options for float binding, one is manually where user can edit the floats
manually and second one is automatically where user needs to select the box of bind
float by assigning the maximum float
value.

2.2.4 Yarn Properties
For editing the yarn properties, user
need to select the option of Yarn
Properties in the File Mane of right click
and select the option of Yarn
Properties. User can change the colour
of yarns, thread count, ply, diameter
factor, twist (count & sense), hairiness,
and price as well.

2.2.5 Density
In the density user can change the Ends
per Inch (EPI) and Picks per Inch (PPI)
of the fabric.

2.2.6 Thread Sequence
Use can change the pattern of thread
sequence in the base of the fabric. The
new thread sequence can be saved and
used further as and when required.
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2.2.7 Switching Colours
Switch colour option swap the colour of warp and weft with each other. Use need to
click on Edit -> Switch Colour Option.

2.2.8 Pattern
Lock/Un
lock
Use can lock the weaving pattern for
the
protecting
the
further
modifications. The same can be UN
locked by the UN lock option.

2.3 Fabric View
2.3.1 Selection of Fabric Component
User need to select a component
of the fabric i.e. Pallu, Body,
Border, Cross Border, Conia,
Skart to view in the window. To the
select the component user need to
click at the Utility on File Menu,
Fabric Settings and then select the
Cloth Type from the list.
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2.3.2 Composite View
This view shows the threads of
warp, weft and extra weft in single
pixel. The base and artwork on the
base are represented as solid.

2.3.3 Grid View
This view is to see the artwork in the
form grid. Grid does not have the
loom parameters i.e. hooks and
picks.

2.3.4 Graph View
The graph view of the artwork depict
all the weaves used in artwork along
with the size of graph. The size of
the graph is represented in the form
of chauks. Suppose a design is
created in 200 hook, it means 50
chauks. In Varanasi, the graph is
calculated based on EPI and PPI.
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2.3.5 Front Side
The front view of the fabric is
shows the yarns in 3 pixels with
the shading effect. This view
gives a fabric look to the design.
User can see all the yarns
separately

2.3.6 Flip Side
Flip view shows the backside
view of the fabric. This view
shows the interlacement of the
thread in the back side of the
fabric by flipping the baric from
one side.

2.3.7 Back Side
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Backside view is just a mirror view
of the fabric as In Varanasi weaver
weave the fabric back side up. The
see the front side of the fabric they
use a mirror. This gives a mirror
look to the weavers.

2.3.8 Front Cut

2.3.9 Rear Cut

2.3.10 Simulation
The application has one, very basic
model of simulation where artworks are
superimposed on the scanned images
of the base fabric. The images of the
base fabric with the different
parameters are saved in to library. User
can chose the type of base fabric and
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set the other parameters of simulation i.e. brightness, contrast,

2.3.11 Zoom (Out)
Zoom-out features helps the user to see
over all look of the fabric. At the zoomout level only colours of the design are
depicted on the base fabric.

2.3.12 Zoom (In)
Zoom-In features provide the facility of
looking the fabric more closely. For
Zoom-In view

2.3.13 Single Repeat
To get the view of the single repeat of
the fabric, user need to click on Utility of
File Menu and then Fabric Settings ->
un-check multiple repeats

https://bunai.medialabasia.in/
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2.3.14 Multiple Repeats
To get the view of the single repeat of
the fabric, user need to click on Utility of
File Menu and then Fabric Settings ->
un-check multiple repeats

https://bunai.medialabasia.in/
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2.4 Save Fabric
After creating, editing the fabric there is the provision of saving the fabric into database.
2.4.1 Public
Public option to save the fabric which will be synchronized with central server and
available for use to other users.
2.4.2 Protected
In the protected option to save, the
fabric which will be synchronized
with central server but other user will
not be able see.
2.4.3 Private
In the private option to save, the
fabric
which
will
not
be
synchronized with central server.
The work done by the user will be kept at local machine only

2.5 Save As
There is Save As option where user can
provide different name of the fabric and
authentication as per need.

2.6 Print Fabric
User can print the fabric in different forms

2.6.1 Print Screen
Print screen gives the facility to print the
fabric which is appearing on the screen.
Fabric Editor ->File -> Print Screen
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2.6.2 Print Grid
Print grid option prints the fabric in the form of black and white grid

2.6.3 Print Graph
Print graph option is for printing the
design in the form of graph after
assigning weaves. This will be a one
page graph.

2.6.4 Print Texture
In case user wants to share the digital copy of the fabric. This option helps to take the
print of texture of the fabric in the form of one repeat.

2.7 Export Fabric
2.7.1 Export the Complete Fabric:
This feature provides the facility to the
user for exporting the fabric including the
supported files of artwork and weaves.
From the Security and confidentiality
aspect, user also has the flexibility to
wipe his complete data from the system
after exporting to the external drive. For
export, user need to select Utility Module
-> Utility File Menu -> Export and user
need to choose the following options

2.7.1.1

Fabric Data

This option provides facility to export all the fabrics of the user to its external drive.

2.7.1.2

Artwork Data

This option is for exporting all the artwork of the user

2.7.1.3

Weave Data

BY clicking on this option, all the weaves created by the user will be exported

2.7.1.4

Export

Export option will export the data to external drive and keep a copy into the database
as well.
https://bunai.medialabasia.in/

23 | P a g e

User’s Manual

2.7.1.5

Export & Delete

This option will export the data to external drive and wipe out user’s data from the
database. This feature is for those users who want to take out their complete data from
the system.
2.7.2 Export as HTML
User can export the fabric with the complete technical details including size, EPI/PPI,
warp, weft, extra weft details as follows:
Fabric Editor -> File -< Export as HTML
Bunai: Fabric_FABRICUSER71_2017-04-21_05-24-23
http://www.medialabasia.in
© 2015-16 Media Lab Asia; New Delhi, India
Fri Apr 21 05:24:23 IST 2017
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2.7.3 Export as Texture
Using this option, user can export the texture (image file .png)
of the fabric in form one repeat.
Fabric Editor -> File -< Export as Texture

2.7.4 Export as Graph
User can export the design in the form of a graph after assigning
weaves. This will be image file .bmp on one single page.

Fabric Editor -> File -< Export as Graph

2.8 Import the Complete Fabric
This feature is for importing the data which was
exported by the user. User can carry his/her data
on the external drive and import as and when
required.
From the Security and confidentiality reason, some
of the user do not want to leave their data on the system. They can export the complete
data and import as per requirement.

https://bunai.medialabasia.in/
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For import, user need to select Utility Module -> Utility File Menu -> Import ->
browse the back of the exported data

2.9 Punch the Punch Cards
After completing the design part, user need to punch the cards to start the weaving.
There are three options for punching the punch cards
2.9.1 Manual Punching
In the manual punching process, user needs a printed graph, punch and punching
plate. The punching plate decide the size of the card which math the punch plate of
the cylinder mounted on jacquard. User manually reads the graph and punch the hole
on the card. This process is very time consuming.
2.9.2 Piano Punching
Piano is the mechanical machine to punch the cards. In the piano punching also user
needs a printed graph. User manually reads the graph and punch the hole on the card.
This process is little bit faster than manual punching.

2.9.3 Punching using Punching Machine
This process takes very less time to punch the cards. Users do not need to carry the
printed graph, a soft of the design is required to give the command to punching
machine. This application supports any punching machine. To give the punching
command user need to go to Fabric Editor Module -> File Menu -> Punch Application
and then select the following parameters.

2.9.3.1

Select Graph Type

Usually punching machine takes the input of the design in
two colors only. So we need to convert the multi colored
design on two colors only and these two colors are
counted as black and white.

2.9.3.2

Single Page-Single Graph

If user wants the complete (with all the colors) in one page
then he/she needs to select this option. In this option user
will get only one

https://bunai.medialabasia.in/

26 | P a g e

User’s Manual

2.9.3.3

Multi Page-Single Graph

2.9.3.4

Multi Page-Multi Graph

2.9.3.5

Superimposed-Single Graph

If the design has more than two colors and user wants to give the
punching in single command then super imposed single graph is
the option where both the colors of the design merged together.
There is no need to give color wise punching of the cards
separately.

https://bunai.medialabasia.in/

27 | P a g e

User’s Manual

2.9.3.6

Superimposed-Single base Graph

If the design has more than two colors and user wants to give the punching in single
command then super imposed single graph is the option where both the colors of the
design merged together. There is need to see base weave give color wise punching
of the cards .

2.9.4 Select Punching Machine (Punch Application)
User need to select the Punching machine application i.e. driver of the punching
machine connected with the computer.
2.9.5 Service Password
User need to enter the service password to give the command of punching from the
security and authentication aspect.

2.10 Open an existing fabric from library
User can open an existing fabric from the
library through File -> Open
When user will click on the Open, an
image browser window will pop up which
shows the fabrics in library. It also
provides searching and sorting options
based on the following parameters viz.
Name, Date, Type. User can select the
particular fabric by clicking on the image.
2.10.1 Search
User can search the fabric by name. User need to enter the starting character of name
of the fabric, the list of fabric will automatically be displayed.
2.10.2 Sort

2.10.2.1

Sort by Date

User has the option to sort the fabric by date (ascending order)

2.10.2.2

Sort by Name

User can sort the fabric by date (ascending order alphabetically)

https://bunai.medialabasia.in/
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2.11 Load Recent
Load recent option for opening the most recent fabric.
GARMENT VIEW Module
Cloth editor module is the play
area for designer where they can
see the design in the form of
complete Saree layout. User can
try the different combinations of
designs and colors.

2.12 Operations
2.12.1 Fabric
Assignment
In this section user need assign the
fabric in each and every section of the
layout. By right click of the specific
section, user can select the fabric
from the library. If user clicked on the
border, an image browser will be
opened with the library of borders
where user can chose the design of
the border.
2.12.2 Fabric CREATOR
This section facilitate users to edit the
fabric. User need to right click on the
section of layout and select fabric
editor option. The selected fabric will
be opened in the fabric editor module
where user can edit the fabric.
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2.12.3 Yarn Properties
This feature gives the flexibility to the
user for changing the warp, weft and
extra weft yarn properties (currently
colour of the yarn). Later on count of
the yarn, ply, twisting, hairiness factor
will be editable.

2.12.4 Fabric Orientation
With this feature, user can change the
repeat pattern of the artwork i.e. ½ drop, 1/3
drop etc. User can rotate the artwork by
selecting the angle and re-size the artwork
in the form of hooks and picks.

2.12.5 Clear
Clear function is to clear the fabric from the layout. This function will not work if user
is switching from fabric editor with some fabric, the same fabric will be depicted in the
cloth editor (as this fabric is having context with the fabric editor).
2.12.6 open
User can open cloth (saree, dress material) from cloth library. User can edit cloth and
see the view in garment view.

2.12.7 save
User can save cloth (saree, dress material) in cloth library. User can see own cloth in
garment view.

https://bunai.medialabasia.in/
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2.13 Layouts
2.13.1
Saree
In Varanasi, Saree has the different layouts in the form of various components of the
Saree i.e. border, cross border, pallu, body.

2.13.1.1

Border across Body and Pallu

In this layout, border goes across the
cross border. The cross border limits
up to the border only.

2.13.1.2 Border
Body Only

across

In some of the cases, border goes up
to pallu only. Pallu part cover the area
of both the borders. Cross borders are
also across border.

2.13.1.3 Single
Border

Cross

Some of the Sarees have only one
side cross border, body part start just
after pallu.
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2.13.1.4

Border with Skart

In this layout, a skart is extra
component along with border, cross
border, pallu and body part of Saree.

2.13.1.5

Saree with Blouse

This layout of the Saree is with Border
Cross Border, Pally, Body and blouse
piece.

2.13.1.6

Custom layout

User can see to saree layout in own choice. User can see part of saree and see the
saree view.

2.13.1.7

All repeat view

User can see to repeat view of fabric in saree layout.

https://bunai.medialabasia.in/
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2.13.2

Other Garments

2.13.2.1

Dress Material Body Only

Dress material having body only, without border.

2.13.2.2

Dress Material with Two Borders

Stole with two side borders

2.13.2.3

Dress Material with One Border

Stole with one side border

2.13.2.4

Custom layout

User can see to dress material layout in own choice. User can see part of dress
material and see the dress material view.

2.13.2.5

All repeat view

User can see to repeat part of dress material view of dress material layout.

2.14 Outputs
2.14.1 Export as Texture
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2.14.2 Print Texture
User can print the texture view
directly.

2.14.3 Simulation2D
View
In the 2D-simulation, the artwork
super imposed on the scanned
image of the base fabric. User can change the other parameters of the simulated view
i.e. bright ness, colour, contrast etc.

3 ( Dobby Weave )
Dobby Weave help users to create different weaves which will be used during the
weave assignment to the artwork.

3.1 Create Weave

To create one repeat of the weave, user need to enter number of warp, weft, shaft
and treadles. After assigning the above parameters, 4 grid will be appeared to the
user i.e. design grid, drafting grid, ti-up grid and peg plan grid. There are to options
to create the weave and select warp colour and weft colour form colour palette.
3.1.1 Design to Drafting
User need create the weave by filling the design grid. Rest of the three grids will be
calculated automatically.
3.1.2 Drafting to Design
If user knows the drafting the design then he/she needs to fill the drafting, ti-up and
peg plan grid, design will automatically reflect in the design grid.
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3.2 Edit
To edit the weaving patter, user can do the following operations

4.2.0 Yarn Properties:
There is provision of select warp yarn colour and weft yarn colour from colour palette
and apply colour.The view of fabric
3.2.1 Insert Warp
There is the provision to insert a warp in the existing weaving pattern. The new warp
will be inserted at the right side of the selected warp.
3.2.2 Delete Warp
To delete a warp, user need to select the war first and then click on the delete warp
option.
3.2.3 Insert Weft
There is the provision to insert a weft in the existing weaving pattern. The new weft
will be inserted below the selected weft.
3.2.4 Delete Weft
To delete a warp, user need to select the war first and then click on the delete warp
option.
3.2.5 Select
To select the area in the design, user need to click on the select option and drag the
selection portion. The selected area will be represented in red colour.
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3.2.6 Copy
User can copy only selected area of the design which can be used to paste at some
other place in the design editor.
3.2.7 Paste
User can paste the copied area in the design editor. The paste will start from the
selected point.
3.2.8 Mirroring
User can Mirroring the selected weave pattern (either vertically or horizontally).

3.2.8.1

Horizontal

For mirroring the specific weave pattern horizontally user will have to click on the
Mirror Horizontal icon in the Edit menu bar.

3.2.8.2

Vertical

For mirroring the specific weave pattern vertically user will have to click on the Mirror
Vertical icon in the Edit menu bar.
3.2.9 Clear
User can clear the design window by clicking on the clear option. After clicking on the
clear, all the windows i.e. drafting, peg plan, ti-up and design window will be blank
(except one point in design window).
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3.3 Operations

3.3.1 Move
User can move weave pattern one unit or 8 unit in Left, Right, Up and down.

3.3.1.1 One Move by 1:
User click move one unit Move left, move Right, Move Up, Move Down. Weave pattern
move desire direction.

3.3.1.2 Move by 8
User click move eight unit Move left, move Right, Move Up, Move Down .Weave
pattern move desire direction.
3.3.2 Tilt
The tilt tool shifts every next line (or column) of the weave for one thread to the
desired direction. The most common use is for fast creation of satin weaves.
3.3.2.1 Right
Tilt right (transforms vertical line to right diagonal).

3.3.2.2 Left
Tilt right (transforms vertical line to left diagonal).

3.3.2.3 Up
Tilt right (transforms vertical line to up diagonal).

3.3.2.4 Down
Tilt right (transforms vertical line to down diagonal).
3.3.3 Rotate
For rotating the whole weave pattern user will have to click on the Rotation icon in
the Operation menu.

3.3.3.1 Clock wise
User can rotate whole weave pattern in clock wise direction.
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3.3.3.2 Anti-Clockwise
User can rotate whole weave pattern in anti clock wise direction.
3.3.4 Inversion
For inverting the weave pattern user will have to click on the inversion icon in the
Operation menu.

3.4 View
The View Menu option of the Weave Editor Window will provide certain operation for
viewing the weaving patterns of the fabric at different view mode.

3.4.1 Zoom
User can see different view of weave pattern.

3.4.1.1 Zoom-In
Zoom-In can be obtained by clicking on the icon under the View menu. Zoom In
increases the size of pixel which represents the thread on the screen this allows the
user to see the weave with more precision and accuracy.

3.4.1.2 Zoom-Out
Zoom out Mode can be obtained by clicking on the icon under the View menu. .
Zoom Out decrease the size of pixel which represents the thread on the screen this
allow user to inspect the detail of the large weave.

3.4.1.3 Normal
Normal Mode can be obtained by clicking on the icon under the View menu. This
Facilitates the user to retain back the zooming level at its default setting.
3.4.2 Textured View
User can see actual view of weave in texture view under View menu.
3.4.3 Tiled View
User can see fabric view of weave in tiled view under View menu.
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4.4.4 Composite View
User can see composite view of weave in view under View Menu.
4.4.5 Front side View
User can see Front side view of weave in view under View Menu.
3.4.6 BACK side View
User can see Back side view of weave in view under View Menu.
3.4.7 Simulation View
User can see simulation view of weave in view under View Menu.
4.4.8 Colorways
User can see different view of many combination of warp and weft yarn colour under
view menu in dobby weave .

3.5 Save/Save AS
For saving the new weave into the library user has to click on Save As icon in the
File menu, this will save the weave with new name inside the library.
For saving an existing weave into database library with modification user will have to
click on Save icon under the File Menu.

3.6 Open
User can open an existing created weave from the library by clicking on Open icon in
the File Menu.
After clicking on Open icon in the File Menu a Window will pop up which shows the
graphical display of the weave to the user.
Open Weave window that provides different searching and sorting options for user to
search the weave Filtering on file name displays the weave which matches the
search filter. Sorting that allows to sort the weave file on the basis of factors such as
:Name –this helps a user to sort on the basis of name.
Date – This option helps user to Sort on the basis of Date updated or last saved.
For e.g., if user last saved the weave file yesterday then with this option he can
directly open the file without searching for particular one in library.
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3.7 Load Recent
User can see previous saved weave in load recent menu bar.

3.8 Import
Dobby Weave provides the facility to the user to import the wif file that contains all the
weaving related information. By clicking on Import icon under the File Menu.
After clicking on Import icon, a file open dialogue box will appear for selecting a specific
WIF file.

3.9 Export
Dobby Weave provides the facility to the user to export the design in wif format.
User can export the weaving information by clicking on Export icon in the File menu.
the facility to the user to export the Weaving Pattern information.

3.10 Print
Weave Pattern editor provides the facility to the user to print the weaving pattern
design.For printing the weaving pattern, user will have to click on Print icon in the
File menu.this will print the weaving pattern on the printer.

3.11 Entering into Fabric creator
In case user switch to the weave editor and enter fabric editor, the selected weave will
be assigned to the base of the fabric.
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4 Artwork creator
The artwork editor helps users to create and edit the artwork. The basic functionality
has been given in the artwork, for the advanced CAD features user need switch to the
design editor. The basic feature are as follows:

4.1 Create
If user want to create a new artwork, a
design editor window will be opened by right
clicking on the canvas after selecting the
create option in the main menu.

4.2 Save
User can save the artwork in to library through save option.

4.3 Open
After clicking on Open icon in the File Menu a Window will pop up which shows the
graphical display of the artwork to the user Open artwork window that provides
different searching and sorting options for user to search the artwork Filtering on file
name displays the artwork which matches the search filter. Sorting that allows to sort
the artwork file on the basis of factors such as :Name –this helps a user to sort on the basis of name.
Date – This option helps user to Sort on the basis of Date updated or last saved.
For e.g., if user last saved the artwork file yesterday then with this option he can
directly open the file without searching for particular one in library.

4.4 Load Recent
User can see previous saved artwork/design in load recent menu bar
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4.5 Edit and transform

4.5.1 Resize
User has the option to change the height and width of an image by entering the
number in height and width text field according to his choice. For Applying changes
to an image user will have to click and apply button.
4.5.2 Reduce Colours
After importing an image, total number of colors in the image are identified and for
reducing the color user will have to drag one color over number of colors from which
it wants to replace all colors with that particular color. For Applying changes to an
image user will have to click Apply Button.
4.5.3 Covert to Grey Scale
User can convert the image into grey scale format by clicking on Grey scale icon/
button. For Applying changes after click convert to grey scale icon.
4.5.4 Convert to Black & White
User can convert the image into black and white format by clicking on Convert to
Black & White button. For Applying changes after click convert to grey scale icon.
4.5.5 Mirroring
User can Mirroring the selected artwork/design (either vertically or horizontally).

4.5.5.1 Horizontal
For mirroring the specific artwork horizontally user will have to click on the Mirror
Horizontal icon in the Edit menu bar.
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4.5.5.2 Vertical
For mirroring the specific artwork vertically user will have to click on the Mirror
Horizontal icon in the Edit menu bar.
4.5.6 Rotation
For rotating the whole artwork user will have to click on the Rotation icon in the
Operation menu.

4.5.6.1 Clockwise
User can rotate whole artwork/design in clock wise direction.

4.5.6.2 Anti-clockwise
User can rotate whole artwork/design in anti-clock wise direction.
4.5.7 Undo
User can undo the edit operation performed by him on the artwork editor to reached
its previous stage.
4.5.8 Redo
User can undo the edit operation performed by him on the artwork editor to reached
its previous stage. It is opposite to undo option.
4.5.9 Graph correction
User can see float and binding of graph /fabric. User can also interchange warp, weft
and extra weft colour.
4.5.10 Fill tool
User can assign weave in design to colour wise with single instance or multiple
instance. It is provide to facilities to assign weave and see the graph of fabric.
4.5.11 Artwork sketch
User can see to sketch of artwork or design in artwork creator.
4.5.12 Repeat orientation
User can see the orientation of artwork/design by using of repeat mode (number of
vertical and horizontal).It is also see layout view of fabric.

4.6 View
User can see different view of artwork/design.
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4.6.1 Zoom-In
Zoom-In can be obtained by clicking on the icon under the View menu. Zoom In
Increases the size of pixel which represents the thread on the screen this allows the
user to see the design/artwork with more precision and accuracy.
4.6.2 Zoom-Out
Zoom out Mode can be obtained by clicking on the icon under the View menu. .
Zoom Out decrease the size of pixel which represents the thread on the screen this
allow user to inspect the detail of the large design/artwork.
4.6.3 Normal
Normal Mode can be obtained by clicking on the icon under the View menu. This
Facilitates the user to retain back the zooming level at its default setting.
4.6.4 Composite View
User can see composite view of artwork/design in view Menu.
4.6.5 Front side View
User can see Front side view of artwork/design in view Menu.
4.5.6 Front Cut View
User can see front cut view of artwork/design in view Menu.
4.5.7 Simulation View
User can see simulation view of artwork/design in view Menu.
4.5.8 Graph View
User can see graph view of artwork/design in view menu.
4.5.9 Grid View
User can see grid view (grid form) of artwork/design in view menu.
4.5.10 composite View
User can see composite view of artwork/design in view menu.
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4.7 Import
Artwork Editor provides the facility to the user to import the png and jpg file that contains all
the image related information. By clicking on Import icon under the File Menu.
After clicking on Import icon, a file open dialogue box will appear for selecting a specific png
and jpg file format.

4.8 Import Refresh
User can edit design/artwork by Arahne paint or MS paint save and click import refresh
icon on artwork editor. It is open editable design/artwork.

4.9 Export
Artwork Editor provides the facility to the user to export the design in png format.

4.10 Paint Application
Artwork Editor provides the facility to the user to add paint application in bunai software.

4.11 Pint Setup
User can set the print properties such as margin size and orientation under file menu.

4.12 Print Preview
User can see print preview before print under file menu.

4.13 Print Texture
User can see print texture format of artwork/design.

4.14 Switch to Fabric Editor
In case user switch to the fabric editor from artwork editor.

5 Fabric Preferences (Construction)
User can set fabric preferences before creating fabric. User can set thread name,
thread color, thread count, thread count unit, thread diameter factor, thread twist, twist
scene, hairiness, thread ply, crimp, thread pattern and loom waste in warp thread.
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5.1 Fabric and Artwork Size
The user need to specify the default size of tehh

5.2 Warp Thread

5.2.1 Thread Name
The name of the thread need to be specified by the user i.e. Silk, Cotton etc.
5.2.2 Thread Colour
User need to specify the colour of the yarn initially.
5.2.3 Thread Count
The yarn count depends on the width of the yarn. The count of yarn expresses the n
umber of weight per units in one length unit
5.2.4 Thread Count Unit
The unit thread count i.e. denier, Tex etc.
5.2.5 Thread Diameter Factor
Diameter factor depends on the types of yarn.
5.2.6 Thread Twist
Shows the twists per meter
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5.2.7 Twist Sense
This define the twist sense i.e. S, Z, or 0(no twist).
5.2.8 Hairiness
Shows the hairiness property of the yarn
5.2.9 Hairiness Probability
Shows the probability of hairs on the yarn.
5.2.10 Thread Ply
Define the no. ply in a thread
5.2.11 Thread Price (Per gram)
The user need to enter the price of the yarn
5.2.12 Crimp
The crimp varies upon the type of yarn.

5.3 Weft Thread
User can set fabric preferences before creating fabric. User can set thread name,
thread color, thread count, thread count unit, thread diameter factor, thread twist, twist
scene, hairiness, thread ply, crimp, thread pattern and loom waste in weft thread.
5.3.1 Thread Name
The name of the thread need to be specified by the user i.e. Silk, Cotton etc.
5.3.2 Thread Colour
User need to specify the colour of the yarn initially.
5.3.3 Thread Count
The yarn count depends on the width of the yarn. The count of yarn expresses the n
umber of weight per units in one length unit
5.3.4 Thread Count Unit
The unit thread count i.e. denier, Tex etc.
5.3.5 Thread Diameter Factor
Diameter factor depends on the types of yarn.
5.3.6 Thread Twist
Shows the twists per meter
5.3.7 Twist Sense
This define the twist sense i.e. S, Z, or 0(no twist).
5.3.8 Hairiness
Shows the hairiness property of the yarn
5.3.9 Hairiness Probability
Shows the probability of hairs on the yarn.
5.3.10 Thread Ply
Define the no. ply in a thread
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5.3.11 Thread Price (Per gram)
The user need to enter the price of the yarn
5.3.12 Crimp
The crimp varies upon the type of yarn.

5.4 Miscellaneous
User can set multiple print, multiple repeat and punch card for machine. User can also
set protection, binding, float size, floating error, vertical repeat and horizontal repeat,
colour palette (pantone colour and web colour), designing charges, punching charges,
properties charges, wages charges, overhead charges, percentage change profit and
max colour use in artwork.

6 Utility
User can convert yarn count, linear measure, weight in different unit.

6.1 Unit Conversion
6.1.1 Yarn Count
User can convert count one unit to other unit.
6.1.2 Linear Measure
User can convert length one unit to other unit in linear conversion.
6.1.3 Weight
User can convert weight one unit to other unit in weight conversion.
6.1.4 GSM Conversion
User can find GSM of fabric.
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6.2 Utility
6.2.1 Application Integration

User can add application with set application name, application type and application
path in utility.

6.2.1.1

Application Name

User need to give a name to the application which will be added.

6.2.1.2

Application Type

The type of application need to be defined.

6.2.1.3

Application path

6.2.2 Simulator
6.2.3 Export File
The path of the exported file need to be specified by the user.
6.2.4 Import File
The import file need to be place at the specific location.

6.3 Library
User can see library of artwork, weave, fabric, color and cloth. User can export, delete
update and change permission artwork, weave, fabric, color and cloth.
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6.3.1 Sorting
User can sorting name or date wise in library.

6.3.1.1
6.3.1.2

Name
Date

6.3.2 Searching
User can search name or type wise in library.

6.3.2.1

Name

The user can search the weaves, designs and fabrics by Name.

6.3.2.2

Type

The user can search the weaves, designs and fabrics by Type.

6.3.3 Update
User can update artwork, weave, color and fabric in library.
6.3.4 Change Permission
User can changes permission public, private and protected of artwork, weave, fabric
and color in library.
6.3.5 Export
User can export library of weaves, design and fabric.
6.3.6 Delete
User can delete artwork, weave, fabric and cloth from library.
6.3.7 Export & Delete
User can export and delete artwork library, weave library, fabric and cloth library.

6.4 Translator
User can translate word English to Hindi.
6.4.1 Create
The need to create his own (localized Language library).
6.4.2 Open
The user can open any Language library.
6.4.3 Save
The user can save only his/her own language Library.
6.4.4 Save As
The user can open the existing language library, edit it an Save As in his/her name.

6.5 Support
6.5.1 Help
The user manual has been integrated in the help section.
6.5.2 Technical Information
Technical specification for this software follows:
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Operating System: Windows & Linux
RAM:

4GB

Processor:

Core i5

Graphics Card:

2 GB dedicated

Java:

Java 7 & above

Flash Player:

Flash Player

Database Engine: MySQL 5.x

6.5.3 About Software
DigiBunai™ aid's the weavers to create digital artwork and translate
the saree design to be loaded to the looms. DigiBunai™ is a first of
its kind Open Source software for Jacquard and dobby weaving.
DigiBunai™ is customized for Banarasi Saree having the unique feature of cloth
editor which works as a play area for designers/weavers. The software is
customizable (local language and library of local designs) and also has the ability
to integrate digital design tool of the user’s choice.

6.5.4 Contact Us

(Section 25 Company under the Ministry of Electronics and IT (MeitY), GoI)

6.5.4.1 Mumbai (Corporate)
Address: Samruddhi Venture Park, Central MIDC Road #2, 4th Floor, Andheri (East),
Mumbai, Maharashtra, 400093
Phone: +91-22-2831-2930/ 31
Fax: +91-22-2837-9158
Email: contact@medialabasia.in
Website: www.medialabasia.in

6.5.4.2 New Delhi
Address: 708-723, 7th Floor, Devika Tower, 6 Nehru Place New Delhi -110019
Phone: +91-11-26443266
Fax: +91-11-26288189

6.5.4.3 Product Support
Phone: +91-11-26443266 (CAD support team)
Email: cadtool@medialabasia.in
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6.5.5 Exit
You need to click on Exit Button to close the application.
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